Logging into NSX UI via OIDC, leading to 'Manager' UI menus persistently loading.
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Logging into NSX UI via OIDC, leading to 'Manager' UI menus persistently loading.

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Article ID: 431090

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Updated On:

Products

VMware NSX

Issue/Introduction

  • When logging into NSX UI, via OIDC, you may experience some of the following headers are failing to load within NSX UI, under UI 'Manager': 
  • Networking:
    - Load Balancers.
    - Distributed Firewall.
  • Security: 
    - Distributed Firewall.
  • Inventory: 
    - Context Profiles. 

Environment

NSX 4.2.3

Cause

  • This occurs due to a misconfiguration, in how the 'Manager' user interface has handled secure session tokens, specifically for OIDC user sessions. This leads to the system attempting to process the missing token, which it does so improperly. As a result, it cannot be processed, which leads to these menus failing to load. 

Resolution

  • The token handling logic is updated within the 'Manager' user interface. This is a known issue impacting VMware NSX.