VSE going down frequently on Devtest server

book

Article ID: 4309

calendar_today

Updated On:

Products

CA Application Test Service Virtualization CA Continuous Application Insight (PathFinder) CA Service Virtualization (DevTest / LISA / VSE / Application Test)

Issue/Introduction

Virtual service has created on server. It is running fine for some time and after some time, VSE component is not responding

Cause

When service is not responding, capture the VSE logs from server and check are there any java.lang.OutOfMemoryError messages in log file.

Sometimes, when allocated memory to component is not enough, JVM used by VSE throws an error as below:

 System.err                     - Exception in thread "ActiveMQ Session: ID:AASSS0000446NP-59277-6676569847-5:13:3" java.lang.OutOfMemoryError: Java heap space

 

Environment

Release: LSASVR99000-8.1-LISA-Server
Component:

Resolution

  If you notice an OutofMemoryError and Devtest component is running with default memory settings, allocate memory in vmoptions file by adding below JVM arguments (Based on memory availability on server) and restart the components.

-Xms1024M 

-Xmx1024M

Additional Information

https://docops.ca.com/devtest-solutions/9-5/en/administering/general-administration/memory-settings