Restart management cluster upgrade
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Restart management cluster upgrade

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Article ID: 430804

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Updated On:

Products

VMware Telco Cloud Automation VMware Telco Cloud Platform

Issue/Introduction

There is a need to retry the management cluster upgrade

Environment

TCA: 3.2

TCP: 5.0.1

Cause

Upgrade did not finish or is processing

Resolution

Update the TCA Manager

  1. SSH login to the TCA-M and enter the postgres DB pod by command
    kubectl exec -it postgres-0 -n tca-mgr – psql -d tca -U tca_admin -h localhost

  2. On the PostgreSQL pod, update the cluster k8s information by SQL command, which should enable the re-upgrade actions triggered from the TCA UI
    update "K8sClusterDetails" set val = jsonb_set(val, '{clusterConfig,kubernetesVersion}', '"v1.28.11+vmware.2"', false) where val->>'clusterName'='<name of cluster>';

Update the TCA-CP 

  1. SSH login to the TCA-CP and enter the PostgreSQL DB pod by command
    kubectl exec -it postgres-0 -n tca-cp-cn – psql -d caas_spoke -U caas_spoke_admin -h localhost

  2. Update the backend cluster status using the following SQL

    UPDATE "management_cluster_statuses"
    
    SET val = jsonb_set(val, '{phase}', '"PostConfig"')
    
    WHERE id = (
    
        SELECT id
    
        FROM "management_clusters"
    
        WHERE name = '<name of cluster>'
    
    );
    
    UPDATE "management_cluster_statuses"
    
    SET val = jsonb_set(val, '{status}', '"Failure"')
    
    WHERE id = (
    
        SELECT id
    
        FROM "management_clusters"
    
        WHERE name = '<name of cluster>'
    
    );
  3. After completing these steps, click the "Upgrade Cluster" button from the TCA UI