Brownfield import of vCenter in VCF 9.x fails at task "Import vCenter vcenter_fqdn.... as a VI Domain"
search cancel

Brownfield import of vCenter in VCF 9.x fails at task "Import vCenter vcenter_fqdn.... as a VI Domain"

book

Article ID: 430731

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer

Issue/Introduction

On the VCF Operations UI - this error is displayed - 

Import operation for import with id ######-###-###-###-######## failed internally. Command was python3 /opt/vmware/vcf/domainmanager/scripts/vcf-import-tool/vcf_brownfield.py import --skip-ssh-thumbprint-validation --sso-user  [email protected] --domain-name <Domainame> --vcenter <vCenter FQDN> --internal-vcf-auth --nsx-deployment-spec-path /tmp/nsxDeploymentSpec.json --skip-nsx-overlay --output-dir /var/log/vmware/vcf/domainmanager/brownfield/######-###-###-###-########/ --non-interactive. Please check the log files located in /var/log/vmware/vcf/domainmanager/brownfield/######-###-###-###-########/ on the SDDC Manager appliance

The SDDC Manager log file /var/log/vmware/vcf/domainmanager/brownfield/######-###-###-###-############ /vcf_brownfield.log file contains this error - 

[YYYY-MM-DD HH:MM:SS,SSS] [ERROR] vcf_brownfield:###: Found the following errors: Found an already imported domain containing the same vCenter: example.com. Only 'sync' operation is allowed on already imported vCenters in SDDC Manager.

Environment

VCF 9.x

Cause

The vCenter Server is already part of an existing import domain, and only the Sync operation is currently permitted to complete the import task.

Resolution

Sync the vCenter in the SDDC Manager by following the steps here -

  1. In VCF Operations, select Inventory > Detailed View.
  2. Expand VCF Instances and browse to the VCF instance that contains the VCF domain you want to sync.
  3. Click the VCF domain name.
  4. Click Actions > Sync Inventory.
  5. Review the information and click Sync Inventory.

Note - If the sync fails with the error below, please open a support ticket with Broadcom Support -

  • Action not available
  • Domain not configured
  • Please configure the domain to use this capability

Additional Information

Manage VCF Domain Configuration Drift