vCenter Server 8.0 upgrade fails at pre-check with error "SELECT PROFILE_NAME, CONFIG_INFO FROM VPX_PROFILE"
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vCenter Server 8.0 upgrade fails at pre-check with error "SELECT PROFILE_NAME, CONFIG_INFO FROM VPX_PROFILE"

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Article ID: 430722

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • When attempting to upgrade VMware vCenter Server (for example, from version 7.0 U3 to 8.0), the pre-upgrade check fails, preventing the upgrade from proceeding.
  • The following error is reported during the pre-upgrade validation phase: Source vCenter Server validation found an issue: Error executing 'SELECT PROFILE_NAME, CONFIG_INFO FROM VPX_PROFILE WHERE TYPE_CODE = 0'. Reason: The operation required too much data to be stored in the specified buffer. Resolution: Make sure your database is configured to meet vCenter Server upgrade requirements.

Environment

  • VMware vCenter Server 7.0.x
  • VMware vCenter Server 8.0.x

Cause

This issue occurs when a corrupted Host Profile in the vCenter Server database (VPX_PROFILE table) is queried during the upgrade pre-check. If the profile is invalid often seen as a 0 KB export, which triggers a buffer size exception and causes the pre-check to fail.

Resolution

To resolve this issue, identify and delete the corrupted or unused Host Profiles from the vSphere Client, and restart the vCenter Server services.

Ensure to take a snapshot of the vCenter Server prior to deleting configurations or proceeding with a major version upgrade.

  • Standalone vCenter Server: Take an online snapshot of the vCenter Server appliance.
  • Enhanced Linked Mode (ELM): Power off all vCenter Server appliances and take offline snapshots of each node.
  1. Log in to the vSphere Client.

  2. Navigate to Menu > Policies and Profiles > Host Profiles.

  3. Review the available Host Profiles and identify any that meet the following criteria:

    • Unused or extremely old profiles.

    • Profiles attached to clusters or hosts that no longer exist.

    • Corrupted profiles (Note: Exporting the profiles to your local machine can help identify corruption, a corrupted profile will typically export as a 0 KB file).

  4. Select the identified Host Profile(s) and detach them from any associated clusters or hosts.

  5. Delete the problematic Host Profile(s).

  6. Establish an SSH session to the vCenter Server Appliance (VCSA) and log in as root.

  7. Restart all vCenter Server services to ensure stale database connections and memory caches are cleared by running the following commands:
    service-control --stop --all
    service-control --start --all

  8. Rerun the vCenter Server 8.0 upgrade pre-check validation.