Node Details shows as unknown on LogInsight Node after upgrade from 8.18.3 to 8.18.5
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Node Details shows as unknown on LogInsight Node after upgrade from 8.18.3 to 8.18.5

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Article ID: 430579

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Updated On:

Products

VMware Aria Operations (formerly vRealize Operations) 8.x

Issue/Introduction

Environment

Aria Operation for logs 8.18.x

Cause

The following error is repeatedly logged in /storage/core/var/loginsight/runtime.log:
[yyyy-mm-dd hh:mm:ss.065+0000] ["https-openssl-apr-443-exec-8"/<node-ip> ERROR] [com.vmware.loginsight.commons.rpc.clientconnpool.ClientPoolsHolder] [Need IP to create Thrift client. Got 'hostname']

Resolution

1. Take Snapshots
  1. Before making any manual changes to the configuration files, take a virtual machine snapshot of all nodes in the cluster.
2. Access the Internal Configuration Page
  1. Open a web browser and navigate to: https://<FQDN_OR_IP_OF_PRIMARY_NODE>/internal/config
  2. Log in using the local admin credentials.
3. Modify the Hostname to IP
  1. Scroll down to the <distributed> section of the XML configuration.
  2. Locate the entry for the Primary node and any affected worker nodes.
  3. Look for the host="<hostname>" attribute.
  4. Replace the <hostname> with the Static IP address of that node.
  5. Click Save at the bottom of the page.
4. Restart Services
     1. If the UI does not refresh to show "Healthy" status within 5 minutes, restart the services on each node via SSH:
     2. SSH into the node as root.
     3.Run the command: service loginsight restart

Additional Information