vSphere "Pre-upgrade check failed due to the following problem: <blank>"
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vSphere "Pre-upgrade check failed due to the following problem: <blank>"

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Article ID: 430570

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

When upgrading vCenter from 7.x to 8.x, you receive an error on the Pre-upgrade check, with a blank for the error message:

The log files for the upgrade (/var/log/vmware/upgrade/upgrade-source-requirements.log) are more helpful, they show repeated messages similar to the following:

2026-02-18T16:20:20.717Z ERROR time_utils Failed to retrieve time from the NTP server: ###.###.###.###
Traceback (most recent call last):
  File "/tmp/vmware-upgrade-temp-dir########/tmpx#######/bootstrap_scripts/time_utils.py", line 152, in _getNTPServerTime
    response, address = client.recvfrom(1024)
socket.timeout: timed out
2026-02-18T16:20:20.717Z WARNING proxy got , retrying ...
2026-02-18T16:20:55.750Z ERROR time_utils Failed to retrieve time from the NTP server: ###.###.###.###
Traceback (most recent call last):
  File "/tmp/vmware-upgrade-temp-dir########/tmpx#######/bootstrap_scripts/time_utils.py", line 152, in _getNTPServerTime
    response, address = client.recvfrom(1024)
socket.timeout: timed out

Cause

The configured NTP servers are unreachable for any of the following reasons:

  1. A firewall is blocking access
  2. The NTP servers no longer exist at the defined addresses
  3. The NTP service is not running on the defined addresses
  4. There is no route to the NTP servers at the defined addresses.
  5. No valid NTP servers are configured

Resolution

Configure using the vCenter Server Appliance Web Console (VAMI):

  1. Log into the vCenter VAMI as root:

    https://<vCenter_IP>:5480

  2. Select Time.

  3. Navigate to Time Synchronization.

  4. Click Edit.

  5. Under Mode, select NTP.

  6. Type in the NTP server(s) on Time servers.

  7. Click SAVE

  8. Retry the upgrade.

Additional Information

See KB 313945, regarding configuring NTP.