Standby Global Manager stuck in "Sync In Progress" state due to port connectivity failure in the NSX
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Standby Global Manager stuck in "Sync In Progress" state due to port connectivity failure in the NSX

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Article ID: 430520

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Updated On:

Products

VMware NSX

Issue/Introduction

The Standby Global Manager (GM) Sync status remains in a "In Progress" state in the NSX manager GUI as shown in the screenshot below:

The vmware/appl-proxy-rpc.log on the NSX manager reveals the following connection errors indicating an inability to route traffic to peer nodes on required synchronization ports:

YYYY-02-02T09:44:51.897Z DR-VX-NSXTG02.1link.pk NSX 2161 - [nsx@6876 comp="global-manager" subcomp="appl-proxy" s2comp="nsx-net" tid="2319" level="INFO"] StreamSocket[5030 Open f:61 i:-1258173070 ? -> ssl://X.X.X.X:1234] on_connect 113-No route to host
YYYY-02-02T09:44:51.897Z DR-VX-NSXTG02.1link.pk NSX 2161 - [nsx@6876 comp="global-manager" subcomp="appl-proxy" s2comp="nsx-net" tid="2319" level="WARNING"] StreamConnection[5030 Connecting to ssl://X.X.X.X:1234 sid:5030] Couldn't connect to 'ssl://X.X.X.X:1234' (error: 113-No route to host)
YYYY-02-02T09:44:51.897Z DR-VX-NSXTG02.1link.pk NSX 2161 - [nsx@6876 comp="global-manager" subcomp="appl-proxy" s2comp="nsx-net" tid="2319" level="WARNING"] StreamConnection[5030 Error to ssl://X.X.X.X.:1234 sid:-1] Error 113-No route to host

Environment

VMware NSX

Cause

Network communication is failing between the Active Global Manager and the Standby Global Manager nodes.

Specifically, network port connections (such as 443, 1234, and 1235) are failing to establish for one or more target GM nodes, disrupting the synchronization sequence.

Resolution

To resolve the issue:

  1. Identify the specific IP addresses of the Standby GM nodes reporting the failure.

  2. From the Active Global Manager, utilize the nc -zv command to test connectivity to the Standby GM nodes over required ports. Example: nc -zv <ip addresss> 1234

  3. If the connection fails, engage the network administration team to ensure all required ports are open and forwarded between the NSX Managers in the environment.

Additional Information

Refer to the official VMware Ports and Protocols document to verify all required ports for NSX Manager and Global Manager communication: https://ports.broadcom.com/home/NSX