Unable to delete TEP IP pool stuck in "In Progress" status in VMware NSX
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Unable to delete TEP IP pool stuck in "In Progress" status in VMware NSX

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Article ID: 430411

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Updated On:

Products

VMware NSX

Issue/Introduction

In VMware NSX, an IP pool appears in a greyed-out state within the NSX Manager UI. The deletion status is continuously stuck displaying "In Progress," preventing the pool from being modified or removed via the user interface.

Environment

VMware NSX 4.x

Cause

The IP pool deletion was initiated before its IP allocations were fully released, causing a stale task to hang.

Resolution

The defect allowing this to occur natively was resolved in VMware NSX 4.1.2.  However, stale database entries can persist into later versions (such as NSX 4.2.3.1), if the task hung prior to upgrading the environment.

Check for current IP Pool allocations.

  1. Check the IP pool allocation before attempting deletion:
    1. In the NSX Manager UI, navigate to Networking > IP Management > IP Address Pools.
    2. Review the Allocation column of the affected IP pool for active IP addresses allocated.
    3. Alternatively, you can check with an API call:
      GET https://<NSX-Manager-IP/FQDN>/api/v1/pools/ip-pools/<pool-UUID>
  2. If there are IPs still shown in the allocation, reconfigure the associated ESXi hosts to use an alternative, active IP pool.
  3. If the object utilizing the IP has already been deleted and the IP has become stale, execute the following API call to force the release:
    POST https://<NSX-Manager-IP/FQDN>/api/v1/pools/ip-pools/<pool-UUID>?action=RELEASE
    
    {
    "allocation_id":"<IP-Address>",
    "allocation_id":"<IP-Address>"
    }
    Note: Include the list of IP addresses or single IP address inside the API body of the POST request.

Remove IP Pool still present in the NSX UI.

  1. Once all IP allocations have been successfully released, execute the following API call to delete the IP pool:
    DELETE https://<NSX-MANAGER-IP-OR-FQDN>/policy/api/v1/infra/ip-pools/<pool-UUID>
  2. Perform a rolling restart of the NSX Manager cluster to clear the stuck deletion task from the system backend if still present.

Additional Information

Please consult the NSX-T API guide for more information:
NSX-T Data Center REST API