vSphere User interface crashes when selecting VM from protection Group.
search cancel

vSphere User interface crashes when selecting VM from protection Group.

book

Article ID: 430344

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction

Whenever a virtual machine is selected from the protection group, the UI for for the SRM appliance crashes like below. 

Environment

VMware Site Recovery Manager 8.x
VMware Live Site Recovery 9.x

Cause

When checking the dr.log from the SRM appliance, we observe this below. 

com.vmware.srm.client.topology.client.view.availability.ExtensionServersView$ServerByPairSetupException: Unable to get server with GUID 'XXXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX'. at com.vmware.srm.client.topology.impl.view.ServersViewImpl.lambda$getServerBy$1(ServersViewImpl.java:158) at com.vmware.dr.ui.tools.reactive.impl.PromiseImpl$ComposeCompletion.complete(PromiseImpl.java:202) at com.vmware.dr.ui.tools.reactive.impl.PromiseImpl$Result.complete(PromiseImpl.java:41) at com.vmware.dr.ui.tools.reactive.impl.PromiseImpl$Completion.lambda$setResult$0(PromiseImpl.java:63) at com.vmware.dr.ui.tools.utilities.ThreadContext.lambda$wrap$1(ThreadContext.java:55) at com.vmware.dr.ui.tools.utilities.ThreadContext.execute(ThreadContext.java:209) at com.vmware.dr.ui.tools.utilities.ThreadContext.execute(ThreadContext.java:185)

This is an indication of a permission issue, as the UI is crashing due to user permissions assigned to the non-administration role. 

When the end user tries to edit virtual machines in protection group, the appliance UI will fail as it will not allow the user from editing existing protection groups. 

Resolution

This is a permission issue on the SRM appliance, the [email protected] account with full rights needs to be used, or an account with the same privileges as the administrator.