NSX Manager UI stops responding and returns HTTP ERROR 503
search cancel

NSX Manager UI stops responding and returns HTTP ERROR 503

book

Article ID: 430322

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • NSX manager UI does load and returns error similar to below.
    This page isn’t working right now
    nsxmgr.corp.local  can't currently handle this request
  • The cluster remains healthy when checked from CLI using get cluster status command.
  • The  /var/log/proxy/envoy_access_log.txt shows logs similar to bleow
    [2026-02-04T12:49:08.190Z] 10.x.x.x 10.y.y.y.y "GET" "/api/v1/transport-nodes/c7b3####-2856-####-ba92-3763####e83b/network/interfaces/vmnic1/stats" "HTTP/1.1" 503 UAEX 0 0 60003 - "10.x.x.x" "Apache-HttpClient/4.5.9 (Java/17.0.10)" "7002####-a84b-####-823d-5dac####ed09" "10.y.y.y:443" "-"
    [2026-02-04T12:49:08.233Z] 10.x.x.x.x 10.y.y.y.y "GET" "/api/v1/transport-nodes/8c84####-266d-####-98d0-35ce####73ed/network/interfaces/vmnic2/stats" "HTTP/1.1" 503 UAEX 0 0 60004 - "10.x.x.x.x" "Apache-HttpClient/4.5.9 (Java/17.0.10)" "83a1####-2a97-####-aa53-2e52####702e" "10.y.y.y:443" "-"

Environment

NSX 4.2.2.x and lower

Cause

The timeout configuration in the HTTPClient used is not taking effect due to a bug and so it holds multiple stale connections leading to a situation where new requests wont be serviced.

Resolution

The issue is resolved in NSX 4.2.3 and NSX 9.0.1 and later releases.

Workaround:
Restart the auth service. Login into the NSX manager as admin user and run: 
restart service auth