Error connect to Teradata using LDAP
search cancel

Error connect to Teradata using LDAP

book

Article ID: 430191

calendar_today

Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

Getting below error when trying to connect with Teradata database using LDAP:

2026-02-18 08:53:15.374 UTC [ERROR] [https-openssl-nio-8443-exec-13] --- [U:patilath][M:POST][P:/api/ca/v1/connectionProfiles/Teradata_Conn_Profile/actions/validate]            c.c.t.c.d.s.TDMDriverManagerDataSource:  Error during open connection: [Teradata JDBC Driver] [TeraJDBC 17.10.00.26] [Error 1014] [SQLState HY000] TeraEncrypt: Error tdgss-stack-trace-begin>>> GSSException: Failure unspecified at GSS-API level (Mechanism level: [TDGSS_ERR_ALL_MECHANISMS_FAILED] All mechanisms failed during credential creation.)

Environment

TDM 4.11.x

Cause

Identified as product bug where the ability to enter the password was disabled when creating the Teradata connection profile with LDAP.

Resolution

The issue has been fixed via TDM Portal patch build 4.11.5019. This build would ask for both username and password to be entered while LDAP is selected. 

The build could be downloaded from below link:

https://support.broadcom.com/external/content/release-announcements/Test-Data-Manager-TDM-Patches/16649