Hub Error: 'Release Not Found. Please check and sync Capabilities from Foundation Management'
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Hub Error: 'Release Not Found. Please check and sync Capabilities from Foundation Management'

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Article ID: 430109

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Updated On:

Products

VMware Tanzu Platform - Hub

Issue/Introduction

A user performing a fresh hub install and attempting to sync capabilities reports the following error:

Platform Services for VMware Tanzu Platform version 10.3.4 release not found. Please check and sync Capabilities from Foundation Management.

Environment

Tanzu Hub

Cause

The primary cause identified was that the capabilities sync was incomplete. The user reported only 104 capabilities synced, which is fewer than the expected 180+ capabilities. This incomplete sync is suspected to be due to a known, potentially recurring bug where the capabilities payload is too large to be fully indexed, especially around new product version releases.

Resolution

To resolve the indexing issue, the following steps were suggested as a temporary workaround:

  • Try a force resync of the capabilities.
  • Regenerate a new token and then wait approximately 15 minutes for the sync to complete.

A permanent fix will be addressed in a future release of Tanzu Hub.