SQL DB endpoint disappeared from Orchestrator inventory
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SQL DB endpoint disappeared from Orchestrator inventory

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Article ID: 430050

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

possible Symptoms:

  • SQL DB endpoint disappeared from Aria Orchestrator inventory under SQL plugin post running "Update Database" Workflow to update the new password. All the database added were missing post running "Update Database"
  • Trying to manually add a Database failing with error
    com.vmware.o11n.plugin.database.DatabaseException: com.microsoft.sqlserver.jdbc.SQLServerException: Login failed for user '<Useraccount>'. ClientConnectionId:########-####-####-########## (Dynamic Script Module name : addDatabase)
  • the Database DNS has changed and is no longer visible in the Orchestrator inventory

Environment

  • Aria Automation 8.18
  • Aria Automation Orchestrator 8.18

Cause

The issue might have occurred due to some invalid configuration stored which prevented the inventory to not completely query the data

Resolution

Be aware that changing the configuration will trigger a service restart!

  1. Within the Orchestrator web client navigate to Assets -> Resources
  2. Change the view to Tree view (found at the right side at the end of the Filter.. line)
  3. Navigate to Library -> SQL -> Configurations
  4. Each database configuration is stored as an xml file
  5. Find the xml configuration for the changed database, search for url to find the connection string
  6. Export the configuration
  7. Either edit the configuration with the known changes like DNS or Port change or otherwise if not known delete the configuration from Orchestrator and re-add the database.
    * If editing the configuration is not possible then disable the SQL plugin in System Settings > Plug-ins, this will trigger a service restart! Once the edit is completed re-enable the plugin.