Aria Automation でストレージプロファイルにデータストアを追加できない、または既存のリンクが削除される
search cancel

Aria Automation でストレージプロファイルにデータストアを追加できない、または既存のリンクが削除される

book

Article ID: 429996

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

免責事項: これは英文の記事  Unable to add datastore in Storage Profile or existing links from datastores to profiles get deleted in Aria Automation (388524) の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

Aria Automationにおいて、ストレージプロファイルへのデータストアの追加が失敗する、あるいはデータストアとプロファイル間の既存のリンクが意図せず削除される場合があります。

問題

  • UI上では以下のようなエラーが報告されます:
    「Timeout in remote operation after 80 seconds. Operation PATCH...」

  • provisioning-service app のログには、以下のようなエントリが表示されます:
    [ERROR: duplicate key value violates unique constraint "uq_storage_profile_association_state_storage_item_id_storage_de"... 

  • デプロイメント操作では、以下のエラーが発生する可能性があります:
    「No matching placement. Error: No storage profiles are matching the disk requirements.」

以下の操作手順を実行することでも、本事象が発生することがあります。

  1. Aria Automation ポータルへのログイン Aria Automation のポータル画面にログインします。

  2. Service Broker へのアクセス Service Broker(または Assembler)を開きます。

  3. ストレージプロファイル画面への移動 [Infrastructure(インフラストラクチャ)] > [Configure(構成)] > [Storage Profiles(ストレージプロファイル)] の順にナビゲートします。

  4. 対象プロファイルの選択 設定を変更したい任意の「ストレージプロファイル」をクリックして開きます。

  5. [Datastores] タブの選択 画面内の [Datastores(データストア)] タブをクリックします。

  6. データストア選択モードの変更 「All datastores listed will be used...(リストされたすべてのデータストアは指定された優先順位で使用されます)」という説明文の下にあるドロップダウンメニューを、[Manually select datastores / clusters(データストア / クラスタを手動で選択)] に変更します。

  7. データストアの追加 [Add +] をクリックし、追加したいデータストアまたはクラスタを選択して [Add] をクリックします。

  8. 変更の適用 ストレージプロファイルの画面に戻り、追加したデータストアがリストされていることを確認します。[Save(保存)] ボタンがアクティブ(クリック可能)になるので、クリックして変更を適用します。

  9. もし、そのデータストアが「以前に追加され、一度削除された後に再度追加された」ものである場合、[Save] ボタンがグレーアウトしたままになったり、UI上で保存処理のインジケーターがいつまでも回り続けたりします。

Environment

Aria Automation 8.18.1 Patch/Cumulative Upgrade #1

Aria Automation 8.18.1 Patch/Cumulative Upgrade #2

Cause

インフラストラクチャの問題により、データストアが一時的に利用不可になったことなどが原因で発生する可能性があります。

Resolution

これは既知の問題であり、VCF 9 リリース、および Aria Automation 8.18.1 用の累積パッチ 3 (Cumulative Patch 3) で修正されています。

この問題は、マルチテナンシーが有効化され、かつ各テナントに同じ vCenter/クラウドアカウントが追加されている構成の Aria Automation 8.18.1 パッチ 3 環境においても影響を及ぼします(これに対する修正は Aria Automation 累積パッチ 4 に含まれています)。

本件に関する潜在的な回避策(ワークアラウンド)を適用するために、Creating a case with Broadcom Support を参照の上、Aria Automation チームへチケットを起票してください。