VM のパワーオン時に「Unable to deploy network」というエラーが発生する
search cancel

VM のパワーオン時に「Unable to deploy network」というエラーが発生する

book

Article ID: 429966

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

免責事項:これは英文の記事「Error: "Unable to deploy network" when powering on VM」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • ネットワーク "Network_Name" をデプロイできない旨のエラーが発生します。
  • エラー スタックには以下のメッセージが含まれます:
    com.vmware.vcloud.net.InadequateNetworkBackingException: Network Pool assigned to this VDC does not have any more available networks.
  • 当該 OvDC 内のすべての VM がパワーオフ状態であるにもかかわらず、ネットワーク プール上ではリソースが消費されているように表示されます。

Environment

VMware Cloud Director 10.x

Cause

vCloud Director データベースの network_backing テーブルに不整合なエントリが残っていることが原因で発生します。

Resolution

  1. vCloud Director データベースのバックアップを取得します。
  2. vCD Provider UI から、当該 OvDC に割り当てられているネットワーク プールを確認します。
  3. network_pool テーブルを照会し、対象 network_pool id を取得します。
    # select * from network_pool where name='network_pool_name';
  4. 取得した network_pool id を使用して、real_network_backing テーブルを照会します。
    # select * from real_network_backing where rnet_id in (select id from real_network where pool_id='network_pool id');
  5. 取得した network_pool id を使用して、network_backing テーブルを照会します。
    # select * from network_backing where pool_id='network_pool id';
  6. network_backing テーブルを更新し、rnet_id を NULL に設定します。これにより、プールの消費量が 0 に解放され、対象 vApp のネットワーク デプロイが可能になります。
    # UPDATE network_backing set rnet_id=NULL where pool_id='network_pool id';
  7. 再度 VM のパワーオンを試行します。