Restarting OpsMan process causes rbac-agent process to fail
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Restarting OpsMan process causes rbac-agent process to fail

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Article ID: 429851

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Updated On:

Products

VMware Tanzu Platform Core

Issue/Introduction

When you restart opsman process with command

sudo service tempest-web restart

this will cause rbac-agent process in hub_tas_agent vm in hub-tas-collector deployment to fail.

The upgrade of opsman will cause the rbac-agent process to fail too, because decryption passphrase is required after upgrade.

Environment

Opsman with Tanzu Hub

Cause

This process fails because restart of opsman process, requires a decryption passphrase to be entered in order to unlock access to the vm. The rbac-agent logs will show the following error until the passphrase is added:

time=2026-02-18T11:24:20.458225198Z caller=logger.go:85 level=error message="error collecting users: uaaClient.ListUsers() returned an error" error="An error occurred while calling https://opsmgr18-FQDN/uaa/Users?count=100&startIndex=1"
time=2026-02-18T11:24:20.458349314Z caller=logger.go:85 level=error error="Could not connect to Ops Manager UAA to sync user role bindings. Please check the connection to the Ops Manager UAA and the credentials provided.  URL: https://opsmgr18-FQDN/uaa CLIENT_ID: platform_services_client_new" error="An error occurred while calling https://opsmgr18-FQDN/uaa/Users?count=100&startIndex=1"

Resolution

Enter the decryption passphrase in OpsMan UI page. The rbac-agent process will then start successfully. If process is not starting run monit restart rbac-agent.