Error: Management cluster update status Update vCenter credentials in Kubernetes Clusters Status: Processing
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Error: Management cluster update status Update vCenter credentials in Kubernetes Clusters Status: Processing

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Article ID: 429752

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Updated On:

Products

VMware Telco Cloud Automation VMware Telco Cloud Platform

Issue/Introduction

  • Logged into TCA Manager, virtual endpoints, select a TCA Control Plane, produces an error for a mgmt cluster that does not exist on the TCACP

  •  This cluster does exist in this particular management cluster

  • Error: (tca-cp) Management cluster update status: 2 total, 1 succeeded, 0 in progress, 1 failed (k8s-mgmt); Step: Update vCenter credentials in Kubernetes Clusters Status: Processing

Environment

TCA: 3.4

TCP: 5.1 

Cause

The failure to update the vCenter credentials is due to stale Management Cluster information in the Management Cluster-related tables in the caas_spoke database in TCA-CP.

Resolution

After confirming that the cluster does not exist. Delete stale mgmt cluster-related entries. 

  1. Get the k8s-bootstrapper-service service IP info from TCA-CP VM:
    kubectl get svc -n tca-cp-cn k8s-bootstrapper-service

  2. Use the curl command to delete the Management Cluster with force:
    curl -X DELETE "http://<service IP from above command>:8888/api/v1/managementcluster/########-####-####-####-############?force=true"

  3. Delete the tkgcontext:
    curl -X DELETE "http://<service IP from above command>:8888/api/v1/tkgcontext/#########-####-####-####-###########"