Error: "LCMVSPHERECONFIG1000010: Invalid property for guest operations" when scaling out VCF Operations for Logs
search cancel

Error: "LCMVSPHERECONFIG1000010: Invalid property for guest operations" when scaling out VCF Operations for Logs

book

Article ID: 429619

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

When adding additional nodes to scale out a VCF Operations for Logs (formerly Aria Operations for Logs) environment, the request fails shortly after submission. This issue specifically impacts environments where Operations for Logs 9.0.x was imported as a single node into VCF Operations using Fleet Management.

On the vCenter side, the "Deploy OVF template" task fails with an error indicating a missing or invalid property for the guest OS.

Error in vCenter:
Invalid value "" specified for property rootpw

Error in Fleet Management Task
Request failed
Error Code: LCMVSPHERECONFIG1000010
Invalid property for guest operations

Log snippet from /var/log/vrlcm/vmware_vrlcm.log on the Fleet Management appliance during component import:

2026-02-03T21:44:17.142Z INFO vrlcm[22402] [pool-3-thread-18] [c.v.v.l.p.a.s.Task] -- Injecting task failure event. Error Code : 'LCMVRLICONFIG40090', Retry : 'true', Causing Properties : '{ CAUSE ####:####:####:... rootPassword YXYXYXYX }' 
com.vmware.vrealize.lcm.common.exception.EngineException: Operations-logs root password is null or empty

The errors incorrectly point you to an issue with the root password for the VCF Operations for Logs component and any attempts the update or remediate the root password result in the same errors

Environment

  • VCF Operations 9.0.x
  • VCF Operations for Logs 9.0.x

Cause

The issue is caused by a credential synchronization failure or a configuration mismatch in Fleet Management. The worker node deployment configurator utilizes a single "Component Password" intended for both the admin and root accounts.

In scenarios where the environment was imported, or if the admin account password in Fleet Management is not properly synced (often due to exceeding specific VCF complexity requirements), the rootpw property is passed as a null or empty value during the OVF deployment.

Resolution

To resolve this issue, you must ensure the passwords in Fleet Management are compliant with VCF requirements and properly synchronized:

  1. Log in to VCF Operations using an account with admin privileges 
  2. Navigate to Fleet Management > Passwords.
  3. Locate the admin account for the VCF Operations for Logs component.
  4. Ensure the password meets these requirements:
    • Does not exceed 20 characters.
    • Only uses supported special characters: @ # $ ^ * !.
  5. Update the password and perform a Remediate or Update action to sync the credentials across the environment.
  6. Retry the scale-out deployment.

Additional Information

Update Passwords for VMware Cloud Foundation Components