ESXi configured with legacy VMFS5 datastore experience psod lsi_mr3
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ESXi configured with legacy VMFS5 datastore experience psod lsi_mr3

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Article ID: 429580

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

ESXi host experiences a psod with backtrace of following:

Panic Message: @BlueScreen: Spin count exceeded - possible deadlock
Backtrace:
 PanicvPanicInt@vmkernel
 Panic_NoSave@vmkernel
 Lock_CheckSpinCount@vmkernel
 SP_WaitLock@vmkernel
 SPLockWork@vmkernel#
 COWCopyWriteDone@esx
 AsyncPopCallbackFrameInt@vmkernel
 AsyncPopCallbackFrameInt@vmkernel
 AsyncCompleteOneIO@vmkernel
 AsyncPopCallbackFrameInt@vmkernel
 FS_IOAccessDone@vmkernel
 AsyncPopCallbackFrameInt@vmkernel
 AsyncCompleteOneIO@vmkernel
 AsyncPopCallbackFrameInt@vmkernel
 PsaScsi_AsyncTokenIODone@vmkernel
 SCSIDeviceCmdCompleteInt@vmkernel
 SCSIDeviceCmdCompleteCB@vmkernel
 SCSICompleteDeviceCommand@vmkernel
 HppScsiCompleteDeviceCommand@(hpp)
 HppCompletePathCommand@(hpp)
 SCSICompletePathCommand@vmkernel
 SCSICompleteAdapterCommand@vmkernel
 ioComp_wld@(lsi_mr3)#
 vmkWorldFunc@vmkernel#
 CpuSched_StartWorld@vmkernel
 Debug_IsInitialized@vmkernel

Environment

Version Details: VMware ESXi 8.0.3 build-24859861

Cause

The root cause for this psod was undetermined, however presence of legacy datastore VMFS-5 is suspected.

Resolution

  1. Presence of VMFS-5 Datastores is suspected as contributing to the cause create new VMFS-6 datastores and migrate to them.
  2. If you encounter this psod and it matches identically please open a case with VMware by Broadcom and reference this KB