Issue:
The Gateway appliance may fail to start and present the following error output in console:
"Setting up Logical Volume Management: No volume groups found"
"UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY"
Cause:
This error occurs regularly when the Gateway appliance is not powered down or restarted properly. Sometimes the issue can occur if there is inconsistency between the date on the Gateway appliance and the date of the virtualization hypervisor platform.
Resolution:
1. Log into the Gateway via direct console. This can be achieved via the actual VMWare Player softwareor via vSphere client for example on virtual appliances, or via ILOM or direct connection for example on hardware appliances.
2. Determine which device maintains the Gateway's primary partition. This will be the partition that is mounted on '/'.
# df -h
3. Run a filesystem check on the partition noted in the previous step.
# fsck /dev/sda -y
NOTE: The value "/dev/sda" may vary in your environment and should be substituted with the value determined in step 2.
4. Upon completion, restart the Gateway appliance.