Local user account no longer visible on the Tenant UI
search cancel

Local user account no longer visible on the Tenant UI

book

Article ID: 429559

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

 The local user account for a Tenant is not visible from the Cloud Director UI

Environment

VMware Cloud Director 10.6.1.x

Cause

Local user name has been changed to a new name via Administration > Access Control > Users in the Tenant portal.

Resolution

To resolve the issue refer to the following steps:

  1. To identify if the user name has been changed you will need to connect to the Cloud Director database:

    sudo -i -u postgres psql vcloud 
  2. Run the following query:

    select  * from usr where name_in_source  = '<missing username>';
  3. If the username and name_in_source is not matching in step 2, that confirm that the username has been changed for the missing Local User.
  4. To edit the username with the correct Local user name from the Tenant Portal, select Administration in the top navigation bar.
  5. in the left panel, under Access Control, click User, and the list of users appear.
  6. Select the Local user name to modify as per step 2
  7. Click Edit and modify the "User Name" with the correct Local User name.