HCX UI に「ESXi host is not accessible from the appliance」というアラートが報告されます。
search cancel

HCX UI に「ESXi host is not accessible from the appliance」というアラートが報告されます。

book

Article ID: 429529

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

免責事項:これは英文の記事「The alert "ESXi host is not accessible from the appliance" is reported in the HCX UI.」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

HCX Manager UI に、特定の ESXi ホストが HCX-IX アプライアンスからアクセスできないことを示す「Critical」アラートが生成される場合があります。
これは通常、新しいサービスメッシュのデプロイ後、またはアプライアンスの再デプロイ後に発生します。

症状:

  • ESXi ホストと IX アプライアンス間のアクセスが利用できないことを示すログが生成されます。
    /common/logs/admin/app.log
    <timestamp> UTC [InterconnectService_SvcThread-6394, Ent: HybridityAdmin, , TxId: <uuid>] INFO  c.v.v.h.s.i.ThumbprintExchanger- [HCX:] The Host host-<number>, appliance <appliance-uuid>, vCenter <vCenter-uuid>, is not Accessible.
  • ログには、IX がポート 80/443 を使用して ESXi ホストへの SSL 接続を確立できなかったことが示されています。
    hbrsrv-1.log
    <timestamp> warning hbrsrv[01760] [Originator@6876 sub=vmomi.soapStub[76] opID=<uuid>] SOAP request returned HTTP failure; <SSL(<io_obj p:0x###, h:38, <TCP '<IX-IP> : <src-port>'>, <TCP '<ESXi-IP> : 80'>>), /sdk>, method: loginBySSLThumbprint; code: 500(Internal Server Error)
    <timestamp> warning hbrsrv[01760] [Originator@6876 sub=vmomi.soapStub[77] opID=<uuid>] SOAP request returned HTTP failure; <SSL(<io_obj p:0x###, h:38, <TCP '<IX-IP> : <src-port>'>, <TCP '<ESXi-IP> : 443'>>), /sdk>, method: loginBySSLThumbprint; code: 500(Internal Server Error)
  • IX アプライアンスと ESXi ホスト管理 IP 間の ping 接続は引き続き成功する可能性があります。
  • 警告にもかかわらず、ネットワーク接続テスト (ICMP、ポート 80/443) では失敗は表示されません。

Environment

VMware HCX

Cause

アプライアンス ログ (hbrsrv.log) と ESXi ホスト ログ (envoy-access.log) を調査すると、ネットワーク パスが開いているものの、IX アプライアンスと ESXi ホスト間の SSL/TLS ハンドシェイクまたはサムプリント交換が HTTP 500 内部サーバー エラーで失敗していることがわかります。

具体的には、IX アプライアンスがポート 80 または 443 で ESXi ホストへの安全な接続を確立しようとすると、loginBySSLThumbprint メソッドが失敗します。
これは、Interconnect アプライアンスとホストの管理サービス間の同期または信頼の問題があることを示しています。

Resolution

通常、この問題は IX アプライアンスの状態を更新することで解決されます。

IX アプライアンスを再展開します。

1. HCX サービス メッシュ タブに移動します。

2. 影響を受けるサービス メッシュを選択します。

3. IX アプライアンスの場合は、[Resync] または [Redeploy] をクリックします。

接続を確認します:

再デプロイ後、HCX ダッシュボードからアラートがクリアされていることを確認します。

IX アプライアンスを再展開してもアラートがクリアされない場合は、影響を受ける ESXi ホストを再起動します。