ESXi Host VMkernel logs shows the Error - "Cannot extend visorfs file /opt/sut/tmp/sutservice_*.log because its ramdisk (sut-tmp) is full"
book
Article ID: 429522
calendar_today
Updated On:
Products
VMware vSphere ESXi
Issue/Introduction
VMkernel Logs shows the below
YYYY-MM-DD|TT:MM:SS.461Z Wa(180) vmkwarning: cpu0:2099932)WARNING: VisorFSRam: 220: Cannot extend visorfs file /opt/sut/tmp/sutservice_2.log because its ramdisk (sut-tmp) is full. YYYY-MM-DD|TT:MM:SS.767Z Wa(180) vmkwarning: cpu0:2099932)WARNING: VisorFSRam: 220: Cannot extend visorfs file /opt/sut/tmp/sutservice_2.log because its ramdisk (sut-tmp) is full. YYYY-MM-DD|TT:MM:SS.640Z Wa(180) vmkwarning: cpu0:2099932)WARNING: VisorFSRam: 220: Cannot extend visorfs file /opt/sut/tmp/sutservice_2.log because its ramdisk (sut-tmp) is full. YYYY-MM-DD|TT:MM:SS.640Z Wa(180) vmkwarning: cpu0:2099932)WARNING: VisorFSRam: 220: Cannot extend visorfs file /opt/sut/tmp/sutservice_2.log because its ramdisk (sut-tmp) is full. YYYY-MM-DD|TT:MM:SS.855Z Wa(180) vmkwarning: cpu0:2099932)WARNING: VisorFSRam: 220: Cannot extend visorfs file /opt/sut/tmp/sutservice_2.log because its ramdisk (sut-tmp) is full. YYYY-MM-DD|TT:MM:SS.855Z Wa(180) vmkwarning: cpu0:2099932)WARNING: VisorFSRam: 220: Cannot extend visorfs file /opt/sut/tmp/sutservice_2.log because its ramdisk (sut-tmp) is full. YYYY-MM-DD|TT:MM:SS.217Z Wa(180) vmkwarning: cpu9:2099932)WARNING: VisorFSRam: 220: Cannot extend visorfs file /opt/sut/tmp/sutservice_2.log because its ramdisk (sut-tmp) is full. YYYY-MM-DD|TT:MM:SS.217Z Wa(180) vmkwarning: cpu9:2099932)WARNING: VisorFSRam: 220: Cannot extend visorfs file /opt/sut/tmp/sutservice_2.log because its ramdisk (sut-tmp) is full. YYYY-MM-DD|TT:MM:SS.436Z Wa(180) vmkwarning: cpu2:2099932)WARNING: VisorFSRam: 220: Cannot extend visorfs file /opt/sut/tmp/sutservice_2.log because its ramdisk (sut-tmp) is full. YYYY-MM-DD|TT:MM:SS.436Z Wa(180) vmkwarning: cpu2:2099932)WARNING: VisorFSRam: 220: Cannot extend visorfs file /opt/sut/tmp/sutservice_2.log because its ramdisk (sut-tmp) is full.
VMkernel Logs also shows
YYYY-MM-DD|TT:MM:SS.803Z In(182) vmkernel: cpu8:2099932)Admission failure in path: host/system/visorfs/ramdisks/sut-tmp:sut-tmp YYYY-MM-DD|TT:MM:SS.803Z In(182) vmkernel: cpu8:2099932)Admission failure in path: host/system/visorfs/ramdisks/sut-tmp:sut-tmp YYYY-MM-DD|TT:MM:SS.803Z In(182) vmkernel: cpu8:2099932)Admission failure in path: host/system/visorfs/ramdisks/sut-tmp:sut-tmp YYYY-MM-DD|TT:MM:SS.803Z In(182) vmkernel: cpu8:2099932)Admission failure in path: host/system/visorfs/ramdisks/sut-tmp:sut-tmp YYYY-MM-DD|TT:MM:SS.803Z In(182) vmkernel: cpu8:2099932)Admission failure in path: host/system/visorfs/ramdisks/sut-tmp:sut-tmp YYYY-MM-DD|TT:MM:SS.803Z In(182) vmkernel: cpu8:2099932)Admission failure in path: host/system/visorfs/ramdisks/sut-tmp:sut-tmp YYYY-MM-DD|TT:MM:SS.803Z In(182) vmkernel: cpu8:2099932)Admission failure in path: host/system/visorfs/ramdisks/sut-tmp:sut-tmp YYYY-MM-DD|TT:MM:SS.803Z In(182) vmkernel: cpu8:2099932)Admission failure in path: host/system/visorfs/ramdisks/sut-tmp:sut-tmp
Environment
ESXi running HPE Hardware
Cause
Smart Update Tools Repository (SUT)
Smart Update Tools for Linux (SUT) is an application which enables firmware and software deployment via the iLO management network using the server's local administrator credentials. SUT can run as a service when working with HPE OneView managed servers or in an On Demand mode
Smart Update Tools for VMware ESXi (SUT) is an application which enables remote firmware and software deployment to HPE OneView managed servers running supported VMware ESXi operating systems via the iLO management network using the server's local administrator credentials HPE Document on (SUT)
This "sutservice" file fills up the space of the RAM disk and hence reporting the error on the VMkernel logs
Resolution
Contact HPE Hardware vendor for more information and further assistance.
Workaround:
Manually remove the files "/opt/sut/tmp/sutservice_2.log" to clear some space. Command - rm /opt/sut/tmp/sutservice_2.log
Additional Information
As per the HPE advisory , issue is resolved in the latest iSUT 6.2.0 (or later)