Sudden reduction in vSAN datastore capacity and free space due to host maintenance mode
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Sudden reduction in vSAN datastore capacity and free space due to host maintenance mode

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Article ID: 429505

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Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms

  • A 'Disk Capacity' alert is triggered in VMware Skyline Health.

  • The available free space on the vSAN datastore decreased overnight. 

  • The reported total capacity of the vSAN datastore also drops

  • One of the nodes in the VSAN OSA cluster is placed into Maintenance Mode for planned activity

 

  • You might receive the following error when attempting a Snapshot creation via Backup Software like Avamar: 

"vSphere Task failed (snapshot error=45):'There are currently ## bytes usable space. The operation requires #### more bytes of usable space."

Environment

VMware vSAN 8.x

VMware vSAN 9.x

Cause

The apparent loss of storage space is due to the vSAN design regarding Maintenance Mode. When a host is placed into Maintenance Mode, its local disks are temporarily removed from the vSAN cluster's aggregate capacity.

Because the vSAN datastore is a shared pool of local storage from all participating hosts, taking one host offline reduces the pool size. This leads to a lower total capacity figure, which mathematically reduces the remaining free space displayed in vSphere.

Cause Validation

Within the vSAN Capacity Overview, the host which is placed into maintenance mode is flagged as not contributing to the cluster capacity.

Resolution

This is an expected behavior. No technical remediation is required.

To restore the datastore to its original capacity:

  1. Complete the planned maintenance activities on the affected host.

  2. Exit Maintenance Mode on the host.

  3. Allow the vSAN cluster a few minutes to re-aggregate the storage providers.