While deploying Virtual Machine from the content library, getting error "Unable to Process template" as the underlying datastore is inaccessible
search cancel

While deploying Virtual Machine from the content library, getting error "Unable to Process template" as the underlying datastore is inaccessible

book

Article ID: 429441

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

While deploying template from the content library, it succeeds the compatibility check with ESXI host, however fails upon clicking Next.

Below error logs are seen in content library logs located at /var/log/vmware/content-library/cls.log
 
status = PREPARING,downloadEndpoint = <null>,checksumInfo = <null>,errorMessage = <null>}, Info (com. vmware. content. library. item. downloadsession. file.info) => {name = VM-Name.ovf,size = ####,bytesTransferred = 0,status = ERROR,downloadEndpoint = <null>,checksumInfo = <null>,
errorMessage = LocalizableMessage (com. vmware. vapi. std. localizable_message) => {id = com. vmware. vdcs. cls-main. download_session_file_error, defaultMessage = Error exporting file VM-Template.ovf. Reason: The provided storage backing Datastore:datastore-############-####-####-####-######### for library ######-####-####-####-######### is inaccessible.
args = [VM-Name.ovf, The provided storage backing Datastore:datastore-######: #######-####-####-####-######### for library #######-####-####-####-######### is inaccessible. ],
params = <null>,
localized = <null>

Environment

VMware vSphere 8.x

Cause

This issue can occur, if the content library files are referencing to a datastore that is inaccessible.

Resolution

  • Validate, why the datastore is inaccessible
  • Fix the inaccessible datastore and perform resync
  • Performing resync will update the vCenter database and template files will start reflecting in the datastore
  • Proceed with deployment of the virtual machine from the template.