NSX Adapter 'Incorrect Credentials' Error and Manual Rotation Solution
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NSX Adapter 'Incorrect Credentials' Error and Manual Rotation Solution

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Article ID: 429390

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Updated On:

Products

VCF Operations

Issue/Introduction

The "TEST CONNECTION" fails with the "incorrect username and password" error message for an NSX cloud account that is part of the VCF stack and has the "System Managed Credentials" checkbox activated.

Error - Failed to establish connection to NSX manager due to an incorrect username or password

The same could also happen for the vCenter cloud account. 

Environment

VCF Operations 9.0 and later

Cause

There could be multiple causes for this issue. Following are the most common ones:

  1. A snapshot was taken from the NSX Manager appliance and then reverted, but the VCF Ops appliance nodes were not.
  2. An environmental issue, which causes performance issues on NSX manager appliance, which leads to service account creation API call timeouts.

Resolution

In the Administration → Integrations page of VCF Operations, expand the VCF Instance and navigate to the domain.

On the domain page, click the NSX tab. Next to 'System managed credentials', click 'Rotate'.
The existing service account gets deleted and a new service account is created. 

 

The same resolution applies for vCenter cloud account as well.