Error "Licenses could not be synchronized with the vCenter systems" in VCF Operations
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Error "Licenses could not be synchronized with the vCenter systems" in VCF Operations

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Article ID: 429366

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Updated On:

Products

VCF Operations

Issue/Introduction

  • In VCF Operations, administrators may experience the error “Licenses could not be synchronized with the vCenter systems.” when attempting to assign a primary license to a vCenter instance from the License Management page. Although the license is displayed correctly and appears available, the Assign License task fails with this error message.

  • Additionally, /storage/log/vcops/log/vcf-licensing-plugin.log  on VCF Operations appliance shows CONNECTION_FAILED errors as below:

    YYYY-MM-DDT##:##:##.####Z NOTICE vcf-licensing-plugin ##### [ops@#### threadId="#####" threadName="pool-##-thread-#####"] [com.vmware.vrops.licensing.vcf.task.AssignEntitlementTaskExecutor.storeCompletedSyncUsageTaskDetailsToDb] - Storing completed sync usage task details to DB: [AssignEntitlementStatus{allocationId='########-#####-####-#####-########', vcServerGuid='########-#####-####-#####-########', vcHostname='<VC_FQDN>', vcAdapterName='', vcfAdapterName='null', status=OK, usageInfo=[], entitlementUsageInfo=[]}, AssignEntitlementStatus{allocationId='########-#####-####-#####-########', vcServerGuid='########-#####-####-#####-########', vcHostname=''<VC_FQDN>'', vcAdapterName='', vcfAdapterName='null', status=CONNECTION_FAILED, usageInfo=[], entitlementUsageInfo=[]}, AssignEntitlementStatus{allocationId=''########-#####-####-#####-########', vcServerGuid='########-#####-####-#####-########', vcHostname=''<VC_FQDN>'', vcAdapterName='', vcfAdapterName='null', status=CONNECTION_FAILED, usageInfo=[], entitlementUsageInfo=[]}, AssignEntitlementStatus{allocationId=''########-#####-####-#####-########'', vcServerGuid='########-#####-####-#####-########', vcHostname=''<VC_FQDN>'', vcAdapterName='', vcfAdapterName='null', status=CONNECTION_FAILED, 

Environment

VCF Operations 9.x

Cause

This issue occurs because the data collection for the specific vCenter Server has stopped or is in a "Failed" state  in VCF Operations

Resolution

To resolve the issue:

  1. Navigate to Administration → Integrations → Accounts in VCF Operations.

  2. Identify the affected vCenter adapter instance.

  3. Verify the adapter status and resolve any data collection issues:

    • Fix certificate validation errors (re-trust certificate if required).

    • Validate credentials.

    • Ensure network connectivity between VCF Operations and vCenter.

  4. Confirm that data collection resumes successfully and the adapter status changes to healthy/collecting.

  5. Once data collection is restored, retry the license assignment by following the steps outlined in the Assign a Primary License to a vCenter Instance” documentation.