Export funcationality hang post upgrading 17.4.3
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Export funcationality hang post upgrading 17.4.3

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Article ID: 429336

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

After upgrading CA Servicedesk manager from 17.3 to 17.4.3, Export functionality fails across all the modules of application. 
Steps to replicate: 
1 : Login to SDM UI. 
2: Search  Request/Incident/Problem/Configuration Item. 
3: Hit export button. 
4: Page hang. 

Excerpt from pdm_tomcat.log: 
----------------------------------------
Jan. 27, 2026 10:31:55 VORM. org.apache.catalina.loader.WebappClassLoaderBase clearReferencesThreads
WARNING: The web application [CAisd] appears to have started a thread named [Log4j2-TF-8-Scheduled-3] but has failed to stop it. This is very likely to create a memory leak. Stack trace of thread

 

Environment

Release: CA Service Desk Manager 17.4.X

Cause

Likely cause of  missing entries from  usp_exlist_format table. 

Resolution

Scenario1:
Revisit Post Install steps
pdm_load -f r17_4_insert.dat
pdm_load -u -f r17_4_update.dat

Scenario 2: 
1: Compare content of usp_exlist_format table from working and non working servers using pdm_extract. 
Likely cause of missing below entry: 
"0" ,"xlsx" ,"1003","application/vnd.openxmlformats-officedocument.spreadsheetml.sheet", "Microsoft Excel (Open XML)" ,"" ,"default.xsl"

2: update the non-working server using pdm_load with the above entry. 

** Please take a backup of the usp_exlist_format table before making any changes. 



Additional Information

https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/ca-service-management/17-4/administering/configure-ca-service-desk-manager/managing-your-database/database-table-replacement.html