HCX - Redeploy HA Group failed
search cancel

HCX - Redeploy HA Group failed

book

Article ID: 429324

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

Redeployment of the HCX Network Extension (NE) HA Group fails with the following error:

Error Message:
Redeploy HA Group failed. Reason: HA Group operation failed for HA Group Id hagroup-#######-####-####-####-####-f1605389ff82. HA Group Redeploy Job failed. HA group reconcile failed. Failed to verify cleanup of appliance backup records.

When you check the HA Group status it could bee seen as degraded or undecided or both.

Cause

This error indicates that the HA Group reconciliation process was unable to complete because the system could not confirm the successful cleanup of existing appliance backup records. As part of the HA Group redeployment workflow, old or stale backup records must be validated and removed. When this cleanup verification fails, the reconciliation process stops, causing the HA Group redeploy operation to fail. 

For further details on these failures, please refer to the following logs on the HCX Manager and NE appliance:
HCX Manager: /common/logs/admin/app.log
NE : /var/log/messages

Resolution

If the task has completed and failed, use the Recover option. If the task did not fail but has been stuck for several hours, the HCX Manager appliance may need to be rebooted before using the Recover option to resolve the issue.

If performing the HCX recovery and rebooting the HCX Manager does not resolve the error, please open a Broadcom support ticket under the HCX product category

Additional Information

HCX NE-HA group state "DEGRADED" with "ACTIVE/UNDECIDED"