Compatibility Issues -"Virtual disk X is a mapped direct-access LUN that is not accessible" alert appears during VM migration
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Compatibility Issues -"Virtual disk X is a mapped direct-access LUN that is not accessible" alert appears during VM migration

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Article ID: 429252

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

VM migration (vMotion or Cold) fails at the compatibility check with the error: Virtual disk 'Hard disk X' is a mapped direct-access LUN that is not accessible.

Environment

ESXi
RDM (Raw Device Mapping)

Cause

The VM has a Raw Device Mapping (RDM). While the VMFS datastore holding the RDM pointer file is available to the destination, the underlying Physical LUN has not been presented/masked to the destination host or cluster.

Resolution

  1. Identify the NAA ID
    1. In vSphere, open the VM Edit Settings and identify the Hard Disk number from the error.
    2. Log into the Source ESXi host via SSH.
    3. Run the following command to find the NAA ID associated with the disk's VML ID: esxcli storage core device list -d vml.xxxxxxxxxxxxxxxxx
    4. Copy the naa.xxxxxxxxxxxxxx identifier.
      For information on finding the naa ID of the device from VML ID on the Storage array and decoding the content of VML ID, see Correlating VML ID with naa ID in ESXi 7.0.x or later

  2. Verify Destination Visibility
    1. In vCenter, select the Destination Host > Configure > Storage > Storage Devices.
    2. Filter the list using the NAA ID found in Step 1.
    3. If the device does not appear, the LUN is not presented to the host.

  3. Fix the Mapping
    1. Engage your storage team and have them map/mask the identified LUN(s) to the destination host or cluster.
    2. On the destination host/cluster, click Actions > Storage > Rescan Storage.
    3. Verify the NAA ID now shows an "Attached" status on the destination.
    4. Re-run the VM migration wizard.

If the issue persists, file a support request with VMware Support and note this Knowledge Base article ID (429252) in the problem description. For more information, see Creating and managing Broadcom support cases.

Additional Information

This Compatibility alert can also appear if the target host was presented with the RDM LUNs with a different LUN ID.
For more information, see Warning: "Virtual disk 'Hard disk' is a mapped direct-access LUN that is not accessible." while migrating or powering on VM with RDMs attached.