BMS re-installation fails after uninstalling vDefend agents
search cancel

BMS re-installation fails after uninstalling vDefend agents

book

Article ID: 429251

calendar_today

Updated On:

Products

VMware vDefend Firewall SSP

Issue/Introduction

In some cases, after an uninstall, re-installation of BMS fails with the error:

/etc/openvswitch/.conf.db.~lock~ : cannot lock file because it is already locked by pid.

This failure is observed in the installation of the 'ovsdb' process.

Environment

Product: vDefend SSP 5.1.1

OS: Any BMS supported Linux Distros

Cause

This occurs when a previous uninstallation does not complete cleanly. The root cause of the incomplete uninstallation is still under investigation. If the uninstall is not clean, then the ovsdb service's configuration lock file (/etc/openvswitch/.conf.db.~lock~) is not removed.  As a result, in the next installation, the ovsdb install process detects the lock file and fails to install.

Resolution

The issue will be fixed in an upcoming release of SSP. 

To resolve this issue manually, remove the residual lock and configuration files (if present) before re-attempting the installation:

1. Log in to the BMS as the root user (or use sudo).

2. Run the following command to remove the lock and config files:

rm -f /etc/openvswitch/.conf.db.~lock~ 

rm -f /etc/openvswitch/conf.db

3. Re-attempt the BMS installation