The VDC associated with this vApp does not have the required network resources to start this vApp.
search cancel

The VDC associated with this vApp does not have the required network resources to start this vApp.

book

Article ID: 429156

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

When powering on vApps you may see the message:

The VDC associated with this vApp does not have the required network resources to start this vApp.

Error:  com.vmware.vcloud.api.presentation.service.BadRequestException: The VDC associated with this vApp does not have the required network resources to start this vApp.
    at com.vmware.ssdc.backend.services.impl.VAppDeploymentManagerImpl.deployVm(VAppDeploymentManagerImpl.java:401)
    at com.vmware.vcloud.vapp.impl.VAppServiceImpl.deployTask(VAppServiceImpl.java:2089)
    at com.vmware.vcloud.vapp.impl.VAppServiceImpl.executeTask(VAppServiceImpl.java:748)
    at com.vmware.vcloud.backendbase.management.system.TaskActivity$ExecutePhase$1.doInSecurityContext(TaskActivity.java:846)
    at com.vmware.vcloud.backendbase.management.system.TaskActivity$ExecutePhase$1.doInSecurityContext(TaskActivity.java:841)
    at com.vmware.vcloud.backendbase.management.system.SecurityContextTemplate.executeForOrgAndUser(SecurityContextTemplate.java:49)
    at com.vmware.vcloud.backendbase.management.system.TaskActivity$ExecutePhase.execute(TaskActivity.java:848)

Environment

10.x

Cause

The Tenant may not have the correct Network Pool or a Network Pool does not exist or there may be some stale entries in the DB.

Resolution

Steps to fix the Vapp power on issue:

  • If you are using isolated or routed network in Tenant then you can refer to KB 381288 to fix network pool configuration.
  • If you are using only direct connection to external network then it involved DB correction. Raise a ticket with Broadcom support \ GSS by referring a KB 142884