vCenter SSO account disappears intermittently in the vSphere CLient
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vCenter SSO account disappears intermittently in the vSphere CLient

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Article ID: 429139

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

A vCenter SSO account goes missing in the vSphere Client. 

Trying to recreate the account reports the error: Another user or group already exists with the same name

The following errors are observed in the vSphere Client logs: /var/log/vmware/vsphere-ui/logs/vsphere_client_virgo.log

[YYYY-MM-DDTHH:MM:SS.823+08:00] [ERROR] nio-##.#.#.#-5090-exec-#### ######## ###### ###### com.vmware.vise.mvc.exception.GlobalExceptionHandler Exception handled while processing request for /ui/events/: org.springframework.web.context.request.async.AsyncRequestNotUsableException: ServletOutputStream failed to write: java.io.IOException: Broken pipe

[YYYY-MM-DDTHH:MM:SS122+08:00] [WARN ] nio-##.#.#.#-5090-exec-#### ######## ###### ###### o.s.w.s.mvc.method.annotation.ExceptionHandlerExceptionResolver Failure in @ExceptionHandler com.vmware.vise.mvc.exception.GlobalExceptionHandler#handle(Throwable, HttpServletRequest) org.apache.catalina.connector.ClientAbortException: java.io.IOException: Broken pipe

 

Environment

VMware vCenter Server

Cause

The user account is not listed in the vSphere Client due to communication failures between the vSphere Client and the vCenter Server.

The error, ClientAbortException: java.io.IOException: Broken pipe indicates that the server-side process attempted to write data to a network socket that had already been closed by the client or an intermediate network device.

Resolution

Investigate the network between the vSphere Client and the vCenter Server.

As a workaround, after ensuring the network is stable, restart the vsphere-ui service using the command: service-control --restart vsphere-ui