DB Load fails with U00000002 EXISTS during transport case load
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DB Load fails with U00000002 EXISTS during transport case load

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Article ID: 429072

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

During the load of a transport case, by default called uc_datat.txt, when running the db load (ucybdbld) utility, the load fails and throws an error:

U00000002 EXISTS

or

U00000002 VORHANDEN

Environment

Version: Any

Cause

The U00000002 message occurs when the utility tries to insert a row into the database with a specific key (oh_idnr) or name and client (oh_name and oh_client respectively).  In the case of loading a transport case, it can happen if the incorrect option is used for unloading the transport case 

Resolution

The following steps can be used to troubleshoot the issue:

  • Update the ucybdbld.ini file to have database=4 under the [TRACE] section
  • Re-run the db load, loading the transport case, and look at the trace file once it fails.
  • Towards the bottom of the file, there will be lines like:

    20260130/105531.503 - U00029108 UCUDB: SQL_ERROR    Database handles  DB-HENV: 68050c60  DB-HDBC: 68051390
    20260130/105531.503 - U00003591 UCUDB - DB error info: OPC: 'SQLExecDirect' Return code: 'ERROR'
    20260130/105531.503 - U00003592 UCUDB - Status: '23000' Native error: '2601' Msg: 'Cannot insert duplicate key row in object 'dbo.OH' with unique index 'UK_OH_Name'. The duplicate key value is (AUTOMICP#CP001, 0).'

    The important part is the point in parentheses, above this is AUTOMICP#CP001 which points to the load trying to load CP001 which already exists in the system. 

If the load is trying to load a server object (like a WP or CP), then the incorrect option was used for the unload of the transport case.  It's very likely that the "Export all data" option was used.

To resolve this, use the "Unload all objects" option for unloading the transport case.

 

If the issue still occurs, follow the steps above to set the trace and open a case with Support; upload the db load log and trace as well as the file that is being loaded into the system.