Hub Identity Provider name greyed out when attempting change after initial install
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Hub Identity Provider name greyed out when attempting change after initial install

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Article ID: 429007

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Updated On:

Products

VMware Tanzu Platform - Hub

Issue/Introduction

  • After initial, successful install of Tanzu Hub, attempting to change the "OIDC identity provider" is blocked because the "Provider name" is greyed out.
  • Attempting to change the Identity Provider to "Internal user store" then back to "OIDC identity provider" doesn't change the greyed out "Provider name" field.
  • Using om cli to override values returns errors like:

    .properties.idp.idp_oidc.oauth_provider_name":["Value cannot be changed after deploy"]

Environment

This has been observed in Tanzu Hub Tile 10.3.4

Cause

This nested property under the OIDC identity provider selector is intentionally frozen after installation. Changing the Identity Provider selector clears the nested property, which blocks the ability to modify configurations after initial deployment due to the property freeze. 

Resolution

Changes are planned to allow modification of the nested property in the event the "Identity Provider" selector is changed and the nested "Provider name" is cleared.

 

 

If you encounter this failure, please open a ticket with Broadcom Support.