Unable to upgrade Node 2 from ITPAM 4.3 SP3 to 4.4 SP5
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Unable to upgrade Node 2 from ITPAM 4.3 SP3 to 4.4 SP5

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Article ID: 428985

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

After successfully upgrading Node 1 to ITPAM 4.4 SP5, Node 2 upgrade is getting stuck with the following error:
JbossInstallerAction::error> Error installing Jboss javax.net.ssl.SSLException: Connection has been shutdown: javax.net.ssl.SSLException: java.net.SocketException: Connection reset
    at sun.security.ssl.SSLSocketImpl.checkEOF(SSLSocketImpl.java:1533)

Environment

ITPAM 4.4 SP5

Cause

The root cause is some intermittent network issue between the nodes, because of which jboss is not properly downloaded/copied during the node 2 install from node1.

Resolution

We have manually replaced JBoss files from node1 to node 2 and proceeded with the installation of node 2.

  1. Node 2 started fine.
  2. Logged into Node 2 via NTLM auto sign-in without form-based login.
  3. Tested Load balancing between the nodes.