Service Catalog - Query not fetching all users for Request for information.
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Service Catalog - Query not fetching all users for Request for information.

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Article ID: 428931

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Updated On:

Products

CA Service Catalog

Issue/Introduction

Service Catalog dropdown fields displaying user lists do not respect the sorting configuration specified in the associated Report Builder query, resulting in unsorted or incorrectly sorted user names.

Environment

Release: CA Service Catalog 17.4.X.

Cause

There is a custom sorting function available in Select box, we are introducing a new attribute called "Enable Sorting" whose default value is true which specifies whether OOTB sorting logic should be enabled on the field or not. If there is an order by in report query, set this attribute to false to retain the existing ordering.
 

Resolution

This issue is part of Roll-up 06 solution.
Please contact support for a point fix. 

Disclaimer: After the fix is installed , each Select field will have an additional attribute called "Enable Sorting". By default, the value will either be empty or true (which indicates custom sorting is enabled). Customer has to set this value to false to disable the sorting behaviour.