ConnectALL fails to start with error "Connection to XXXXXX refused."
search cancel

ConnectALL fails to start with error "Connection to XXXXXX refused."

book

Article ID: 428878

calendar_today

Updated On:

Products

ConnectAll On-Prem ConnectALL

Issue/Introduction

After starting the connectall-broker.service and connectall-core.service, the connectall-orphan.service fails immediately after starting and causes the connectall-core.service to fail as well.

Environment

4.x

Cause

This is because of the database being not accessible/reachable from ConnectALL Server. Below error can be seen in catalina.out for UI.

Caused by: com.zaxxer.hikari.pool.HikariPool$PoolInitializationException: Failed to initialize pool: Connection to 127.0.0.1:5432 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.

Resolution

Check if the database service is running and accessible from ConnectALL server.
Restart ConnectALL services and verify if the access is restored.