ServiceNow adapter failed to complete with adapter errors.
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ServiceNow adapter failed to complete with adapter errors.

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Article ID: 428828

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Inability to complete ServiceNow integration successfully.  ServiceNow debug logs indicate duplicates VM's CI records in ServiceNow with identical object_id and vcenter_uuid values.  

ServiceNow debug long run log will indicate many of the duplicate values in longrun-<date-of-the-log>-ServiceNowAdapter_<increment-log-number>.log 

....  matchResourcesForCmdbSync.warn - CI Class cmdb_ci_vmware_instance returned 2 CIs that have the same matching identifiers object_id, vcenter_uuid object_id=vm-XXXXX|vcenter_uuid=XXXXXXXXX-XXXX-YYYY-ZZZZZZZZ. None of these are listed as previously managed by this adapter. We cannot determine which is correct so a resource match could not be made. This impacts deleting removed resources/relationships in the CMDB and creating custom groups in Aria Operations.

Environment

Aria Operations for Integrations

Cause

Duplicate CIs in ServiceNow

Resolution

From within ServiceNow, query the cmdb_ci_vmware_instance table . Delete or merge the duplicates so that only one CI exists for each unique identifier combination.


Please reach out to Support if the error matches exactly as indicated from this KB.

Additional Information

This issue is very specific to ServiceNow Integration and should not be applicable to any other adapter integration due to how ServiceNow handles data integrity and that required to sync with Aria Operation upon integration. Data will need to be cleaned up from within ServiceNow.