DCI doesn't reset DC value for a CG after a policy switch
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DCI doesn't reset DC value for a CG after a policy switch

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Article ID: 428778

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Updated On:

Products

Dynamic Capacity Intelligence

Issue/Introduction

The MIN and MAX values for a Capacity Group (CG1) were temporarily set to 360 (they were set to 350 by the active policy Policy1) via DCI Overwrite command.

After a few minutes, an automatic policy switch occurred. This new policy (Policy2) has MIN/MAX set to 350 for that CG but the Defined Capacity is not changed to 350 but kept to 360, even if when the Overwrite period expired.

Environment

Dynamic Capacity 2.0

Cause

A new system/LPAR (LPAR1), belonging to that CG, is not defined in the policy that just started (Policy2):

DCI1100I: NEW SYSTEM cccc/LPAR1/LPAR1 FOUND AND ADDED TO POLICY 

This affected the DCI management for the CG1 Capacity Group also, which stopped receiving capacity changes, as stated by the following messages:

DCI1100E: WARNING: NEW SYSTEM cccc/LPAR1/LPAR1 IS NOT MANAGED AND WILL AFFECT GRP/CG CALCULATION 
DCI1100E: WARNING: NEW SYSTEM cccc/CG1/ IS NOT MANAGED AND WILL AFFECT GRP/CG CALCULATION     

Resolution

Add the LPAR1 system to the Policy2 policy.

Additional Information

See DCI1100E message description, where you can read the following:

DCI has identified that the active policy does not include the LPAR that has a DCI Agent communicating with the Controller. 
DCI automatically includes the LPAR into the active policy and assigns that LPAR the UNMANAGED profile. 
DCI does not take any capping actions about that LAPR but includes that LPAR usage in the calculations across the environment. Group and Capacity Group management calculations are adjusted to take account of the usage of the additional LPAR. If the LPAR is part of a Capacity Group definition in HMC, then that Capacity Group is treated as UNMANAGED, disregarding the policy definition. For more information about policies, see Manage a Policy.