NSX Management Plane Upgrade stuck at 70%
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NSX Management Plane Upgrade stuck at 70%

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Article ID: 428713

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Updated On:

Products

VMware NSX

Issue/Introduction

  • NSX Manager upgrade is stuck at 70% in the UI for the affected NSX manager node
  • The command 'get service install-upgrade' on the affected NSX Manager shows the error message below:

    Upgrade info:
    From-version: 4.2.2.1.0.24765087
    To-version: 4.2.3.3.0.25171321

    Upgrade steps:(Timelines)
    download_os [2025-10-16 13:36:32 - 2025-10-16 13:36:57] SUCCESS
    shutdown_manager [2025-10-16 13:47:10 - 2025-10-16 13:48:40] SUCCESS
    install_os [2025-10-16 13:48:40 - 2025-10-16 13:49:36] SUCCESS
    migrate_manager_config [2025-10-16 13:49:37 - 2025-10-16 13:49:42] SUCCESS
    pin_ui [2025-10-16 13:49:42 - 2025-10-16 13:49:47] SUCCESS
    switch_os [2025-10-16 13:49:47 - 2025-10-16 13:49:48] SUCCESS
    reboot [2025-10-16 13:49:48 - 2025-10-20 07:17:15] SUCCESS
    start_manager [2025-10-17 05:16:42 - 2025-10-17 05:18:18] FAILED <-----------*************

    ------ Output of last step start ------

    Status:

    wait_for_proton: resp_status: HTTPStatus.INTERNAL_SERVER_ERROR, body: None

    Stdout: Removed /config/.resume_upgrade flag

    Starting start_manager upgrade script

    Creating /.eula/.eula_accepted.txt.

    Migrated /os/bak/.eula/.upgrade_eula_accepted.txt to /.eula/.eula_accepted.txt successfully.

    Setting file permissions for eula

    Removing eula.txt

    Proton service did not start within the allotted time.

  • The option to retry the upgrade is not available in the UI
  • The NSX Manager is not responding to pings
  • ifconfig on the NSX manager does not show the eth0 interface, only loopback is seen
  • Attempts to bring up the interface using the command ifup eth0 show that the IP address/netmask  has "//" as shown in the error below

    root@nsxmanager:~# ifup eth0

    Error: any valid prefix is expected rather than "#.#.#.#//##".

    ifup: failed to bring up eth0

Environment

VMware NSX 4.2.x

Cause

  • The Proton service did not start because the affected NSX Manager is unable to reach other NSX Managers within the cluster.
  • The eth0 interface on the NSX manager is not coming up because the IP address has an invalid netmask prefix (//) - "#.#.#.#//##"

Resolution

Workaround: 

  • To complete the upgrade process, reconfigure the IP address of the NSX manager with the commands below to make it reachable over the network:
    ifconfig eth0 #.#.#.# netmask #.#.#.#
    route add default gw #.#.#.#
  • Once upgrade is complete, redeploy all the affected NSX managers using the correct subnet mask syntax by following the steps in Replace a manually deployed NSX Manager node

Additional Information