NFA wiped all data after my disk drive filled up
search cancel

NFA wiped all data after my disk drive filled up

book

Article ID: 428658

calendar_today

Updated On:

Products

Network Observability Network Flow Analysis

Issue/Introduction

While using Network Flow Analysis you may run into a scenario where the disk drive has filled up and the Data Retention process has deleted all historical data. 

Environment

All verisons of Network Flow Analsis to version 25.4.4.

Cause

As stated in the Data Retention documentation, starting in 21.2.10 within the, install_path/Netflow/bin/dataretention.properties file. The "prunePriorityLatestData" property by default, is set to "true"; instead of pruning old data, the harvester stops processing the new incoming data. If the property is set to "false"; the old data is pruned as determined by the following data retention service rules.

The issue is that the installers from 21.2.10 to 25.4.4 are setting this value to false where we documented it should be set to true (the universally wanted behavior).

Resolution

Starting with NFA 25.4.5, new installs and upgrades will set the correct default value of "true" for the prunePriorityLatestData parameter in the install_path/Netflow/bin/dataretention.properties file.

To check and manually change your NFA versions on prior version, please navigate to install_path/Netflow/bin/dataretention.properties and set the prunePriorityLatestData parameter to "true" instead of "false" and than restart the CA NFA Data Retention Service.