After restoring the HCX 9.0 backups, the HCX Admin (port 9443) is inaccessible
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After restoring the HCX 9.0 backups, the HCX Admin (port 9443) is inaccessible

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Article ID: 428630

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Updated On:

Products

VMware HCX

Issue/Introduction

  • You have created an HCX backup file in HCX 9.0.
  • After deploying the OVA with basic network settings, accessing the admin interface (port 9443), and proceeding with a restore, the process completes, however, once the HCX backup is restored, you can no longer access the HCX Admin (port 9443).
  • The main appliance UI (port 443) is fully accessible and shows the restored data, such as site pairings.
  • The following errors are observed in /common/logs/appliance-management/appliance-management.log
    <timestamps> UTC [main, , ] ERROR o.s.boot.SpringApplication- Application run failed
    org.springframework.context.ApplicationContextException: Failed to start bean 'webServerStartStop'; nested exception is ####.####.####.WebServerException: Unable to start embedded Tomcat server
    <...>
    Caused by: org.springframework.boot.web.server.WebServerException: Unable to start embedded Tomcat server

Environment

VMware HCX

Cause

This issue occurs because a file goes missing during the Backup and Restore process.

Resolution

If you believe you have encountered this issue, open a support case with Broadcom Support and refer to this KB article.

For more information,  see Creating and managing Broadcom support cases.