VMware Identity Manager (vIDM) Power-On Operation Fails with Error Code LCMVSPHERECONFIG1000084
search cancel

VMware Identity Manager (vIDM) Power-On Operation Fails with Error Code LCMVSPHERECONFIG1000084

book

Article ID: 428614

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • An attempt to power on VMware Identity Manager (vIDM) nodes from VMware Aria Suite Lifecycle Manager (LCM) fails with the following error:

    Error Code: LCMVSPHERECONFIG1000084

    Unable to extract the Virtual Machine Managed Object Reference ID, due to generic system error.
    Failed to power on VM having hostname <VIDM_Node_FQDN>. Retry after providing the required details
    Optionally, the check could be skipped for the given host, by setting the vidmPowerOnSkip to 'true' after powering on
    the VM directly trom the
    vCenter.com.vmware.vrealize.Icm.common.exception.vcenter.VMWithNamelPAndHostNameNotFoundException: Failed
    to find a VA with ip : "<VIDM_Node_IP>", hostname : '<VIDM_Node_FQDN>'.

  • You might see similar errors in the /var/log/vrslcm/vmware_vrslcm.log file

    com.vmware.vrealize.lcm.vidm.common.exception.VidmPowerOnException:  Failed to power on VM having hostname <VIDM_Node_FQDN> . Retry after providing the required details. Optionally, the check could be skipped for the given host, by setting the vidmPowerOnSkip to 'true' after powering on the VM directly from the vCenter.com.vmware.vrealize.lcm.common.exception.vcenter.VMWithNameIPAndHostNameNotFoundException: Failed to find a VA with ip : '<VIDM_Node_IP>', hostname : '<VIDM_Node_FQDN>'.
     at com.vmware.vrealize.lcm.vidm.core.task.VidmClusterPowerOnNodesTask.execute(VidmClusterPowerOnNodesTask.java:202) 
     at com.vmware.vrealize.lcm.vidm.core.task.VidmClusterPowerOnNodesTask.retry(VidmClusterPowerOnNodesTask.java:245) 
     at com.vmware.vrealize.lcm.automata.core.TaskThread.run(TaskThread.java:60) 
     at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) 
     at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) 
     at java.base/java.lang.Thread.run(Unknown Source)

Environment

Aria Suite Lifecycle 8.18.x
VMware identity Manager 3.3.7

Cause

This issue is caused by the root (/) partition reaching 100% utilization on the vIDM appliance.

When the root partition is full, the operating system cannot complete critical networking services or write necessary temporary files during the boot process. Consequently, the vIDM appliance fails to initialize its IP address, making it unreachable and "invisible" to the Aria Suite Lifecycle Manager during the power-on verification sequence.

Resolution

Ensure that sufficient disk space is available on the root partition of the affected vIDM appliance.

To resolve the issue:

  1. Clean up unnecessary files or logs to free up disk space or

  2. Add additional disk space to the appliance.

Follow the instructions outlined in KB 376193 to properly clean up or extend the disk on the vIDM appliance.

Once adequate disk space is available, retry the power-on operation from VMware Aria Suite Lifecycle Manager.