Reset the credentials for the default Policy Manager administrator in a software-based Gateway
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Reset the credentials for the default Policy Manager administrator in a software-based Gateway

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Article ID: 42860

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Updated On:

Products

CA API Gateway

Issue/Introduction

The Layer 7 Gateway appliance comes with certain scripts and tools to perform certain simple administrative tasks. If the Gateway application is deployed in a non-appliance configuration (i.e., a software-based installation) then some of these tools will not be present. The Gateway appliance contains a script for resetting the administrative credentials and this script is not present in a software-based installation

Environment

API Gateway 9.x with Mysql 5.7.5

Cause

If the Policy Manager credentials are locked or lost then the Policy Manager will not be accessible with that particular set of credentials. If the credentials are lost or locked then they will need to be reset.

Resolution

The credentials can be modified using a particular series of SQL queries run against the Gateway database. To manually unlock and reset the credentials, do the following:

1. Log into the server running the Gateway application
2. Access the MySQL prompt (`mysql ssg`)
3. Run the following SQL queries (substituting the value "username" with the appropriate username):

DELETE FROM logon_info WHERE login='username';
UPDATE internal_user SET password='$6$S7Z3HcudYNsObgs8$SjwZ3xtCkSjXOK2vHfOVEg2dJES3cgvtIUdHbEN/KdCBXoI6uuPSbxTEwcH.av6lpcb1p6Lu.gFeIX04FBxiJ.' WHERE name='username';

4. Exit the MySQL prompt (`exit;`)
5. Attempt to log in via the Layer 7 Policy Manager with the original username and the password set to "password".
6. Reset the current administrative credentials to a secure password.