HCX NE Appliance Incorrectly Displays "RECONFIGURE" During Service Mesh edit.
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HCX NE Appliance Incorrectly Displays "RECONFIGURE" During Service Mesh edit.

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Article ID: 428534

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Updated On:

Products

VMware HCX

Issue/Introduction

When modifying the HCX service mesh configuration, such as increasing the number of appliances, the HCX UI may detect unchanged settings as differences. Consequently, the NE appliance may display as "Reconfiguring" on the “Ready to Complete” preview screen.
For example, despite the Compute Profile and vSphere Client showing 0 CPU/Memory reservations for NE appliances, the HCX workflow incorrectly detects a configuration drift, suggesting the appliance must be redeployed or reconfigured.

Environment

VMware HCX

Cause

The issue is caused by a database inconsistency within the HCX Manager.
While the Compute Profile is set to "No Reservation" (0), the internal HCX database entry for a specific appliance may have its cpuReservation or memoryReservation values incorrectly set to "100". During the Service Mesh update process, HCX compares the desired state with the recorded state in the database. If a mismatch is found, it triggers a "RECONFIGURE" action.

Resolution

To resolve this inconsistency, perform a resync on the Service Mesh.
HCX UI:
Interconnect > Service Mesh > RESYNC

If the problem persists after running "RESYNC", please open a case with Broadcom Support for assistance.
See Creating and managing Broadcom support cases for details on opening a case.