Creation or Execution of Jobs failure
search cancel

Creation or Execution of Jobs failure

book

Article ID: 428465

calendar_today

Updated On:

Products

VMware Smart Assurance Network Observability

Issue/Introduction

Creation or Execution of Jobs fails with the following error on NCM:

com.powerup.configmgr.server.services.scheduler.SchedulerException: SchedulerException.RetrieveTasksForJobFailed

Environment

All Supported NCM releases

Cause

Check for the error messages on the Application Server, $VOYENCE_HOME/ncmcore/logs/server.log file

  • If you are to find messages about unable to create or process any job requests as it is running into "No such file or directory" under /data/base/<######> directory.
  • Check on the Database server if the files mentioned on the server.log exist on the database
  • If the files are genuinely missing, this could lead to the said error messages about job processing on NCM

Resolution

You may choose to revert to the last known & valid backup of the database. 
Reference Steps: Steps to Backup And Restore Database in NCM Distributed Setup

Alternatively, you may choose to restore the last known & valid snapshot of the database VM.

Additional considerations for database & VM snapshot mechanism is available here: https://knowledge.broadcom.com/external/article/331246