The VMware Cloud Director Container Service Extension appliance does not respond to remote connections
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The VMware Cloud Director Container Service Extension appliance does not respond to remote connections

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Article ID: 428444

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • When attempting to access the VMware Cloud Director Container Service Extension (CSE) server appliance via SSH, the connection does not succeed even though the system is powered on and the network address is responsive.
  • Attempts to log into the command line session via the virtual machine virtual console hang indefinitely.

Environment

VMware Cloud Director Container Service Extension 4.2.3 

Cause

The root partition is out of space and services cannot respond appropriately since they are unable to write to this storage. Currently, the CSE logs do not rotate and the primary log for the CSE service (/root/cse.log) can consume a substantial amount of space if the appliance has been running for a prolonged period of time.

Resolution

In order to remediate this issue, perform the following steps:

  1. Restart the appliance and enter single user mode, as in the following article:

    Resetting root password in VMware Cloud Director

  2. Confirm that the root partition (/) is fully utilized:

    df -h

  3. Review the items on the partition and clear unnecessary items. In particular, review the log file sizes in the root home directory:

    ls -lah /root/

    If the cse.log is excessively large, copy the file to a remote system and truncate or remove the file.
  4. Restart the appliance.

Additional Information

CSE log management changes are being considered for a future release of VMware Cloud Director Container Service Extension.