DWH Jobs are in Waiting after enabling DWH Sync
search cancel

DWH Jobs are in Waiting after enabling DWH Sync

book

Article ID: 428437

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Load Data Warehouse jobs - Full and Incremental are scheduled, but not running since DWH Sync (also known as Instantaneous Sync) was enabled, or they run but not at scheduled times. 

"DWH Sync" is also known as "Instantaneous Sync" and executes stored procedure CLARITY_DWH_SYNC_SP. This is the real-time DWH synchronization on updating data in Clarity as opposed to the Clarity Load Data Warehouse job. For more information, check Broadcom Data Warehouse Documentation

Environment

All Supported Clarity releases with DWH Sync enabled 

Cause

This is expected as the Instantaneous sync is incompatible with Load Data Warehouse job to avoid data synchronization issues and locks

Resolution

Since DWH Sync is incompatible with Load DWH job: 

  • When DWH Sync is hanging, Load DWH will be in Waiting state and will not be running as per design. 
  • DWH Sync is not a UI job so you will not be able to see that it is incompatible in UI and it also cannot be unset
  • Once DWH Sync completes, then Load Data Warehouse job will run and also complete as expected
  • If DWH Sync is hanging for a long time, it can be reset by following the steps in KB Reset DWH Sync